Androidデバイスにてflash-all.sh実行時にfastboot too oldと表示される場合の解決方法

Android OSダウングレードの方法

事象

OSダウングレードをしようとしたら、以下のエラーが発生。

C:\platform-tools>sh flash-all.sh fastboot too old; please download the latest version at https://developer.android.com/studio/releases/platform-tools.html
Code language: JavaScript (javascript)

環境はWindows。
(Mac/Linuxだとコマンドは./flash-all.shだが、同じ手順で解決可能)

原因

バージョンを確認しているだけなので、強制的に無視して通すことが出来る。

解決法

flash-all.shをVS Code(又はその他のテキストエディタ)で開き、以下4行をコメントアウト。

if ! [ $($(which fastboot) --version | grep "version" | cut -c18-23 | sed 's/\.//g' ) -ge 2802 ]; then echo "fastboot too old; please download the latest version at https://developer.android.com/studio/releases/platform-tools.html" exit 1 fi
Code language: JavaScript (javascript)

再度コマンドを叩けば正常動作する。

その後、別のエラーが出た場合は下記記事を参照されたし。

(参考)
https://forum.xda-developers.com/t/pixel-3-xl-only-fastboot-but-doesnt-accept-commands.3904235/

その他の記事はこちら
[TouchDesigner]OSC in DATにてUnable to bind port errorと表示される場合の解決法
【実録】症状は何日で治る?後遺症対策は可能??実際に新型コロナ(ステルスオミクロン)にかかったので自宅療養中に色々実践してみた【体験談】
副業初心者が気軽に稼ぐならココナラが最強!スキルなしでできる仕事を紹介
起業するための資金調達の方法7選【自己資金なしでも起業は可能】
OpenBCI GUIにてNetworking-Test-Kitでプロトコルの値がうまく送受信できない問題の解決法

まる。

Python歴3年のフルスタックエンジニア&ヨギー。
大学は心理学、趣味はヘルスケア全般。

最近は自作脳波デバイスのチューニングに勤しみ中。
お仕事の依頼はDMもしくはメールにて。

↓アートとかの趣味アカ。よかったらみてね。٩(๑❛ᴗ❛๑)
Insta:@malmal0v0

まる。をフォローする
タイトルとURLをコピーしました